Connects to any signal across any vendor stack and powers adaptive AI Operatives that expose, detect, and neutralize cyberattacks.
Atlas Operations CenterSee what our SOC sees, review investigations, and see how we are protecting your business.
Technology IntegrationsAtlas connects to any signal across your current security tools. Whatever you're running, we're running with you.
Extend your team with immediate expertise, hands-on remediation, and the human accountability layer that boards, regulators, and cyber insurers require.
Threat Response UnitProactive threat intelligence, original threat research and a world-class team of seasoned industry veterans.
Response and RemediationPairs machine-speed containment with human judgment, delivering full threat response that's policy-bounded, reversible, and explainable.
MDR that moves first, multi-signal attack surface coverage, and 24/7 Elite threat hunters working as one continuous security program across any vendor stack.
Get unlimited Incident Response with threat suppression guarantee- anytime, anywhere.
Full alignment to the five-stages of CTEM operations; scope, discover, prioritize, validate, and mobilize against exposures attackers would use against you.
Flexible MDR pricing and packages that fit your unique security requirements.
Entry level foundational MDR coverage
Comprehensive Next Level eSentire MDR
Next Level eSentire MDR with Cyber Risk Advisors to continuously advance your security program
Stop ransomware before it spreads.
Identity ResponseStop identity-based cyberattacks.
Zero Day AttacksDetect and respond to zero-day exploits.
Cybersecurity ComplianceMeet regulatory compliance mandates.
Third-Party RiskDefend third-party and supply chain risk.
Cloud MisconfigurationEnd misconfigurations and policy violations.
Cyber RiskAdopt a risk-based security approach.
Mid-Market SecurityMid-market security essentials to prioritize.
Sensitive Data SecurityProtect your most sensitive data.
Cyber InsuranceMeet insurability requirements with MDR.
Cyber Threat IntelligenceOperationalize cyber threat intelligence.
Security LeadershipBuild a proven security program.
On May 5th, 2026, Palo Alto Networks disclosed CVE-2026-0300 (CVSS: 9.3), a critical zero-day buffer overflow vulnerability that impacts the User-ID Authentication Portal (aka Captive…
On April 29th, 2026, cPanel disclosed a critical Authentication Bypass vulnerability, tracked as CVE-2026-41940 (CVSS 9.8), that impacts the control panel solutions cPanel and Web Host…
eSentire is The Authority in Managed Detection and Response Services, protecting the critical data and applications of 2000+ organizations in 80+ countries from known and unknown cyber threats. Founded in 2001, the company’s mission is to hunt, investigate and stop cyber threats before they become business disrupting events.
About Us Leadership Careers Event Calendar → Newsroom → Aston Villa Football Club →We provide sophisticated cybersecurity solutions for Managed Security Service Providers (MSSPs), Managed Service Providers (MSPs), and Value-Added Resellers (VARs). Find out why you should partner with eSentire, the Authority in Managed Detection and Response, today.
Search our site
Multi-Signal MDR with 300+ technology integrations to support your existing investments.
24/7 SOC-as-a-Service with unlimited threat hunting and incident handling.
We offer three flexible MDR pricing packages that can be customized to your unique needs.
The latest security advisories, blogs, reports, industry publications and webinars published by TRU.
Compare eSentire to other Managed Detection and Response vendors to see how we stack up against the competition.
See why 2000+ organizations globally have chosen eSentire for their MDR Solution.
In recent months, eSentire's Threat Response Unit (TRU) has observed an increased use of Microsoft Teams phishing involving IT/helpdesk impersonation. To help organizations identify and guard against this threat, we are sharing a Microsoft Sentinel query and mitigation guidance.
Microsoft Teams allows organizations to easily collaborate and communicate with each other. It includes a built-in feature that allows users to share their screens and give control to their IT/helpdesk team when needed. While this feature is valuable for troubleshooting, it also presents a risk to users.
In a typical attack scenario, the threat actor persuades the target to download remote monitoring and management (RMM) tools or grant control during chat/call sessions leading to the installation of additional malicious applications. In some cases, victims were contacted by fake IT/helpdesk staff following an increased volume of email spam.
This technique, known as email bombing, adds urgency and relevance to the social engineering attack. TRU discussed email bombing in our July 2025 TRU Intelligence Briefing.
Our team has observed a common pattern in this new phishing campaign method, which involves using trial Microsoft domains that have not been verified or connected.
While it is important to periodically review external domains users interact with, the domains we have observed typically follow the format: <userName>@<domainName>.onmicrosoft.com. This format allows threat actors to use domain names that impersonate IT/helpdesk departments and create generic helpdesk usernames.
Threat actors begin by creating a temporary domain name and user that typically includes keywords such as "helpdesk," "IT," or "Support", etc. This pattern is often repeated in the username creation. The next stage of the attack involves messaging users of a targeted organization via Microsoft Teams.
Although users receive a prompt indicating an external message is received, the use of keywords like "IT", "Helpdesk", and "Support" may lead them to believe they are having a safe interaction with their internal team.
At this stage, the threat actors can persuade the user to either download an attachment or share their screen and give control which will lead to a compromise account / endpoint.
Use the following Microsoft Sentinel threat hunt query to identify Microsoft Teams messages that have IT/helpdesk keywords in the User Name, Chat Name, or Domain Name fields. This requires ingesting Office Activity logs using the Data Connector: Microsoft 365 (formerly, Office 365), Data Type: Microsoft 365 (formerly, Office 365).
See Connect Data Sources to Microsoft Sentinel Using Data Connectors for more information.
OfficeActivity
| where RecordType == "MicrosoftTeams" and CommunicationType == "OneOnOne"
| where isnotempty(UserId)
| extend User_Domain = tostring(tolower(split(UserId, "@", 1)[0]))
| where User_Domain contains ".onmicrosoft.com"
| where (tolower(UserId) matches regex @"(help|desk|support|^tech|tech$|tech\s|assistance|troubleshoot|admin|^it|it$|it\s)" or User_Domain matches regex @"(help|desk|support|^tech|tech$|tech\s|assistance|troubleshoot|admin|^it|it$|it\s)") or (tolower(UserId) matches regex @"(help|desk|support|^tech|tech$|tech\s|assistance|troubleshoot|admin|^it|it$|it\s)" and tolower(ChatName) matches regex @"(help|desk|support|tech|assistance|troubleshoot|admin|it)")
| summarize TimeGenerated = max(TimeGenerated) by ChatThreadId, UserId
To learn how your organization can build cyber resilience and prevent business disruption with eSentire’s Next Level MDR, connect with an eSentire Security Specialist now.
GET STARTEDThe eSentire Threat Response Unit (TRU) is an industry-leading threat research team committed to helping your organization become more resilient. TRU is an elite team of threat hunters and researchers that supports our 24/7 Security Operations Centers (SOCs), builds threat detection models across the eSentire XDR Cloud Platform, and works as an extension of your security team to continuously improve our Managed Detection and Response service. By providing complete visibility across your attack surface and performing global threat sweeps and proactive hypothesis-driven threat hunts augmented by original threat research, we are laser-focused on defending your organization against known and unknown threats.