What We Do
How we do it
Our Threat Response Unit (TRU) publishes security advisories, blogs, reports, industry publications and webinars based on its original research and the insights driven through proactive threat hunts.
View Threat Intelligence Resources →
Mar 15, 2023
CVE-2023-23397 - Microsoft Outlook Elevation of Privilege Zero-Day Vulnerability
THE THREAT On March 14th, as part of Microsoft’s monthly Patch Tuesday release, the company disclosed a critical, actively exploited vulnerability impacting Microsoft Office and Outlook. The…
Read More
View all Advisories →
About Us
eSentire is The Authority in Managed Detection and Response Services, protecting the critical data and applications of 2000+ organizations in 80+ countries from known and unknown cyber threats. Founded in 2001, the company’s mission is to hunt, investigate and stop cyber threats before they become business disrupting events.
Read about how we got here
Leadership Work at eSentire
Mar 20, 2023
Exertis and eSentire Partner to Deliver 24/7 Multi-Signal MDR, Digital Forensics & IR Services and Exposure Management to Organisations Across the UK, Ireland, and Europe
Basingstoke, UK– 20 March, 2023. Leading technology distributor, Exertis, announced today that it has bolstered its cybersecurity services, adding eSentire, the Authority in Managed Detection and Response (MDR), to its Enterprise portfolio of offerings. eSentire’s award-winning, 24/7 multi-signal MDR, Digital Forensics & Incident Response (IR), and Exposure Management services will be available…
Read More
e3 Ecosystem
We provide sophisticated cybersecurity solutions for Managed Security Service Providers (MSSPs), Managed Service Providers (MSPs), and Value-Added Resellers (VARs). Find out why you should partner with eSentire, the Authority in Managed Detection and Response, today.
Learn more
Apply to become an e3 ecosystem partner with eSentire, the Authority in Managed Detection and Response.
Login to the Partner Portal for resources and content for current partners.
Security advisories — Nov 01, 2022

OpenSSL Vulnerability Disclosed

2 minutes read
Speak With A Security Expert Now


On November 1st, 2022, OpenSSL disclosed two high severity vulnerabilities impacting OpenSSL versions above 3.0.0 and below the patched version of 3.0.7, as well as applications with an affected OpenSSL library embedded. The notable vulnerability is tracked as CVE-2022-3602: a Buffer Overflow vulnerability. A threat actor may exploit CVE-2022-3602 to cause Denial-of-Service (DoS) or Remote Code Execution (RCE). In an attack scenario, this vulnerability is most likely to be exploited in email-based attacks, although remote attacks are possible in certain configurations. Currently, there is no indication of real-world attacks or publicly available Proof-of-Concept (PoC) exploit code.

All systems using vulnerable versions (3.0.0 -> 3.0.6) should apply the patch as soon as possible. Due to the scope of OpenSSL use, the vulnerability impacts many products and vendors will be required to release updates. The eSentire Threat Intelligence team assesses with medium confidence that threat actors will exploit this vulnerability in the future.

What we’re doing about it

What you should do about it

Additional information

OpenSSL is a library used for cryptographic purposes, especially in network connections. For example, web servers often use OpenSSL to establish encrypted HTTPS connections. In addition, mail servers and VPN protocols such as OpenVPN also use OpenSSL to establish encrypted communication channels. The library can be found in many products, including network devices, embedded systems, and container images.

The pre-announcements of CVE-2022-3602 described this issue as CRITICAL. Further analysis has led this to be downgraded to HIGH as it cannot be exploited in most widely used architectures and platforms. Exploitation would require a vulnerable TLS client to connect to a malicious server. Further, the bugs were introduced as part of Punycode decoding functionality, which is currently only used for processing email address name constraints in X.509 certificates. However, any OpenSSL 3.0 application that verifies X.509 certificates received from untrusted sources, should be considered vulnerable. This includes TLS clients and TLS servers configured to use TLS client authentication. 

Docker has stated publicly that approximately 1000 images are impacted and will be mitigated shortly – please follow Docker guidance here.

The second vulnerability addressed by OpenSSL on November 1st, 2022, is CVE-2022-3786. This is a buffer overflow vulnerability that may result in Denial-of-Service. OpenSSL 3.0.7 addresses both CVE-2022-3786 and CVE-2022-3602.

Known Impacted Products: (Note: This list is not exhaustive)

NCSC is maintaining a list of impacted and unaffected software. The page continues to be updated at the time of writing.


[1] https://www.openssl.org/news/secadv/20221101.txt
[2] https://mta.openssl.org/pipermail/openssl-announce/2022-November/000241.html
[3] https://mta.openssl.org/pipermail/openssl-announce/2022-October/000238.html
[4] https://www.openssl.org/blog/blog/2022/11/01/email-address-overflows/
[5] https://github.com/NCSC-NL/OpenSSL-2022
[5] https://www.docker.com/blog/security-advisory-critical-openssl-vulnerability/

View Most Recent Blogs