A vulnerability affecting Oracle Database Servers has been identified and could allow a remote attacker to take complete control of the affected system. After establishing control over the affected system, the threat actor may also gain shell access to the underlying server [1]. This vulnerability is being tracked as CVE-2018-3110 and security patches have been made available by Oracle [2]. At the time of publishing it is not believed that CVE-2018-3110 has been exploited in the wild, but the low level of complexity along with high severity would make this an attractive target for threat actors. eSentire Threat Intelligence assess with medium confidence that this vulnerability will be weaponized quickly and affected systems should be patched as soon as possible. 

What we’re doing about it

  • eSentire Threat Intelligence is monitoring this topic for additional information

What you should do about it

  • After performing a business impact review, apply the released Oracle security patches
  • Ensure password policy follows security best practices
  • Apply the principle of least privilege [3

Additional information

The source of the vulnerability has been traced back to the Java VM component of Oracle Database Server. This component can be exploited by a threat actor with Create Session privileges to compromise the Java VM component and take control of the Oracle Database.

Affected Oracle Database Server:

  • Windows: 11.2.0.4, 12.2.0.1, 12.1.0.2
  • Unix or Linux: 12.1.0.2

Sources:

[1] http://www.oracle.com/technetwork/security-advisory/alert-cve-2018-3110-5032149.html#AppendixDB  

[2] https://cve.mitre.org/cgi-bin/cvename.cgi?name=2018-3110

[3] https://nvd.nist.gov/800-53/Rev4/control/AC-6

eSentire Media Contact

Rebecca Freiburger | eSentire | [email protected] | +1 226-924-4679

Ready to start the conversation about cybersecurity?

Let's Talk